Как добавить DHCP опцию на оборудовании Mikrotik RB2011UiAS-RM

Помимо IP-адреса, DHCP также может сообщать клиенту дополнительные параметры. Эти параметры называются опциями DHCP. Разберем как добавлять DHCP опции на оборудовании семейства Mikrotik.

 

Добавление DHCP опции с помощью командной строки

Все опции пишутся в Hex коде. Для преобразования IP-адреса в Hex код, можно воспользоваться калькулятором тут.

 

Добавление DHCP-опции:

/ip dhcp-server option add name=TFTP code=150 value=0x0A07074E

Привязка DHCP-опции к локальной сети:

/ip dhcp-server network set numbers=0 dhcp-option=TFTP

Проверяем:

/ip dhcp-server network print detail 0 address=10.5.5.0/24 gateway=10.5.5.1 dns-server="" wins-server="" ntp-server="" caps-manager="" dhcp-option=TFTP

 

Добавление DHCP-опции с помощью интерфейса Windox

Запускаем Winbox, переходим IPDHCP Server, во вкладку Options (1), добавляем новую опцию нажимаем (2).

Заполняем (3):

  • Name — произвольное имя добавляемой опции.
  • Code — задается код DHCP-опции.
  • Value — указывается значение опции в Hex формате (калькулятор Hex тут) или в текстовом формате заключенный в ‘ ‘ скобки (прим. ‘10.7.7.78’).

 

Привязка добавленной DHCP-опции к локальной сети, переходим IPDHCP Server, во вкладку Networks(1), редактируем необходимую локальную сеть (2). В свойствах локальной сети, в пункте DHCP Options (3), указываем добавленную опцию.

 

Вот так добавляется DHCP-опция на оборудовании Mikrotik.

 

Понравилась или оказалась полезной статья, поблагодари автора

 

БесполезноСлабоватоПриемлемоОтличноПревосходно (3 голос(ов), в среднем: 5,00 из 5)
Загрузка...

Оставить ответ

четыре × 5 =