Настройка Autoprovision на телефонах Yealink в связке CISCO + VLAN + DHCP + TFTP

Рассмотрим как реализовать Autoprovision на телефонах — Yealink в связке с оборудованием Cisco, технологии VLANDHCP (на базе Windows Server 2012 R2).

 

Исходные данные:

      • Телефоны Yealink T22P с WAN и LAN портами
      • TFTP-сервер на Debian 8 Jessie (установка)
      • Коммутатор Cisco WS-C2960-48PST-L
      • Настроенные VLAN
        • 10 — телефоны
        • 11 — компьютеры
      • Развернутый DHCP-сервер на Windows Server 2012 R2 с двумя областями:
        • Telephone (10.10.10.0/24)
        • Computers (10.10.11.0/24)

Задача:

Необходимо чтобы телефон Yealink, выполнял автоматическую настройку (голосовой трафик направлял по VLAN 10, а трафик от подключенного ПК направлялся по VLAN 11), регистрацию SIP транка.

 

Настройка коммутатора Cisco

На портах коммутатора Cisco предусмотрена специальная функция, которая позволяет определить VOIP трафик и завернуть его в указанный VLAN.

 

Настраивается порт таким образом (правильный способ):

interface FastEthernet0/1
description WORKSTATIONS + VOIP
switchport access vlan 10
switchport mode access
switchport voice vlan 11
spanning-tree portfast

 

Указываем на VLAN интерфейсах адрес DHCP-сервера:

interface vlan 10
ip helper-address 192.168.1.3

interface vlan 11
ip helper-address 192.168.1.3

 

 

Альтернативный вариант настройки порта, без использования (voice vlan), а использование порта как качестве trunk.

interface FastEthernet0/1
description WORKSTATIONS + VOIP
switchport mode trunk
switchport trunk allow vlan 10,11
switchport native vlan 10
Не рекомендую его использовать, так как на некоторых телефонах (прим. Yealink T21), данный вариант настройки порта, работал не корректно. Поэтому рекомендую использовать (voice vlan) 

 

Настройка DHCP-сервера

В созданной области Telephone (10.10.10.0/24) необходимо добавить «Опцию». Переходим в параметры области и добавляем параметр со значением IP-адреса TFTP-сервера:

 

Теперь при подключении телефона к локальной сети, он определит TFTP-сервер.

 

Настройка Autoprovision

Для настройки Autoprovision будет использовать TFTP-сервер (самый оптимальный вариант на мой взгляд).

 

Настройка телефонов производится через конфигурационные файлы (.cfg), которые бывают двух типов:

  1. Общий файл конфигурации, для каждой модели отдельный
  2. Индивидуальный файл конфигурации, для настройки отдельных параметров телефона

 

Список названий общих файлов конфигураций:

T18 - y000000000009.cfg
T19 - y000000000031.cfg
T20 - y000000000007.cfg
T21 - y000000000034.cfg
T22 - y000000000005.cfg
T23 - y000000000044.cfg
T26 - y000000000004.cfg
T28 - y000000000000.cfg
T29 - y000000000046.cfg
T32 - y000000000032.cfg
T38 - y000000000038.cfg
VP530 - y000000000023.cfg
W52P-Base - y000000000025.cfg
T41 - y000000000036.cfg
T42 - y000000000029.cfg
T46 - y000000000028.cfg
T48 - y000000000035.cfg

 

Рассмотрим самый базовый и основной набор параметров телефона (Yealink T22P). Содержание файла конфигурации (y000000000005.cfg) для настройки базовых параметров телефона:

!version:1.0.0.1
forward.always.on_code = *72
forward.always.off_code = *73
network.vlan.internet_port_enable = 1
network.vlan.internet_port_vid = 11
network.vlan.pc_port_enable = 1
network.vlan.pc_port_vid = 10
local_time.time_zone = +3
local_time.time_zone_name = Russia(Moscow)
local_time.ntp_server1 = 192.168.7.3
local_time.ntp_server2 = %NULL%
lang.wui = Russian
lang.gui = Russian

 

Для настройки отдельных параметров (таких как SIP аккаунт) используется конфигурационный файл с именем MAC адреса телефона (прим. 00156511e1ce.cfg  — это файл конфигурационный для телефона с МАК адресом 00156511E1CE). Содержание файла конфигурации для настройки SIP аккаунта:

#!version:1.0.0.1
account.1.enable = 1
account.1.label = 1234
account.1.display_name = 1234
account.1.user_name = 1234
account.1.auth_name = 1234
account.1.password = 123
account.1.sip_server.1.address = 192.168.7.2

 

Для более удобного способа формирования конфигурационных файлов, можно воспользоваться генератором конфигураций:

Yealink_Configuration_Generator_Tool_2.0.0.16_V83.rar

 

 

Понравилась или оказалась полезной статья, поблагодари автора

 

БесполезноСлабоватоПриемлемоОтличноПревосходно (Еще нет оценок)
Загрузка...

Оставить ответ

пять + 20 =